This jar contains entries whose certificate chain is not validated.

When we try to verify APK using jarsigner, somehow, we might got this warning :

1
2
3
4
5
6
jar verified.

Warning:
This jar contains entries whose certificate chain is not validated.

Re-run with the -verbose and -certs options for more details.

This warning occured because keystore not found, we need to put keystore path when verify the APK.
Example:

1
/usr/java/jdk1.7.0_11/bin/jarsigner -verify -verbose <our APK> --keystore <our-keystore>

But, if this warning still occur, please check your keytool and jarsigner already in same JDK or not. There is possibility that we generate the key using keytool JRE 1.6, meanwhile jarsigner is coming from JDK 1.7. Please check the keytool and jarsigner path.

Comments

  1. This problem appeared with java jdk 1.7 so you can resolve this problem
    by uninstall this Java version and install JDK-1.6 Update 30
    Hope help you

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>